¿alguien sabe configurar un router con dd-wrt/OpenWRT como extensor de wifi?

tglaria

InExperto
Tengo un router D-Link DIR-600 Rev.B.
Quiero extender el rango del wifi del módem que da internet dejando todos los dispositivos dentro de la misma red y, si es posible, que el wifi de entensión tenga los mismos parámetros que el wifi original (es decir, tener sólo un solo SSID en el hogar).

Para esto entiendo que debo usar un Wireless Repeater Bridge.
Sigo los pasos al pie de la letra, pero por más que lo intento no tengo internet.

Puedo conectar el router como cliente al módem, agarra IP y tiene acceso a internet, pero si lo conecto como repetidor no me puedo conectar al router pues no agarro IP en los equipos que se conecten a él (al desactivar el servidor DHCP en el router) y el router no ve el módem.

Alguno tiene alguna idea ?
 

Exte3

Capo
Probé con esa también, pero no hubo caso que me funcionara.
Simplemente al desactivar e DHCP no me puedo conectar al router.
Dejaste con IP fija la red lan para poder acceder a ella si conectas algo con IP fija dentro del segmento?

Enviado desde mi Redmi Note 8 mediante Tapatalk
En un rato te subo capturas de mi configuración
 

tglaria

InExperto
Mi configuración actual:
módem de Movistar: 192.168.1.1, rango de IP 81-219

Configuración del DIR-600 (con OpenWRT 17-01):
Interfaz LAN:
Protocolo: IP estática
IPv4: 192.168.0.1
Gateway/Custom DNS: 192.168.1.1
DHCP Server: Desactivado
Firewall-zone: lan, repeater_bridge. wwan

Interfaz "repeater_bridge":
Protocolo: relay bridge
Local IPv4 Address: 192.168.1.109 (esta CREO que es la del modem de Movistar, lamentablemente no pillo dónde configurarla en el módem)
Relay between networks: lan + wwan
Firewall-zone: lan, repeater_bridge. wwan

Interfaz Wireless:
SSID: WifiMovistar
Mode: Client

SSID: WifiMovistar2
Mode: Master
 

Exte3

Capo
En el router de movistar anda a "Menu->Red Local->Mapa de la Red Local" y ahí te saldra la IP que tiene asignada al router luego pones esa en el repeater
 

pitzyper

Online
El segmento LAN por defecto de Movistar es 192.168.1.0/24, por lo que la IP 192.168.0.1 está fuera de ese segmento, o bien te cambias a 192.1681.x o extiendes el segmento al pasar a máscara /23 (255.255.254.0).

Saludos
 

tglaria

InExperto
En el router de movistar anda a "Menu->Red Local->Mapa de la Red Local" y ahí te saldra la IP que tiene asignada al router luego pones esa en el repeater
Me sale solo la IP en el módem de Movistar, sin el nombre del disositivo, pero pude confirmar la IP conectandome por ssh al router DIR600.

El resto de los parámetros pareciera que los tengo correctamente, pero hay algo que tengo mal configurado.
El router DIR600 tiene internet (puedo hacer ping desde el router a internet) pero los clientes conectados a éste no tienen acceso a internet aunque le configure una IP estática.
 

tglaria

InExperto
El segmento LAN por defecto de Movistar es 192.168.1.0/24, por lo que la IP 192.168.0.1 está fuera de ese segmento, o bien te cambias a 192.1681.x o extiendes el segmento al pasar a máscara /23 (255.255.254.0).

Saludos
Esa es la idea.
El router repetidor debe estar en una red independiente de la red de origen.
Así funciona la aplicación del OpenWRT.
No sé el porqué.
 

Exte3

Capo
Me sale solo la IP en el módem de Movistar, sin el nombre del disositivo, pero pude confirmar la IP conectandome por ssh al router DIR600.

El resto de los parámetros pareciera que los tengo correctamente, pero hay algo que tengo mal configurado.
El router DIR600 tiene internet (puedo hacer ping desde el router a internet) pero los clientes conectados a éste no tienen acceso a internet aunque le configure una IP estática.
Entonces el problema pareceria estar entre el lan y el repeater_bridge

Prueba configurar la IP en lan en 192.168.2.1

Por si acaso instalaste el paquete luci-proto-relay ?

Enviado desde mi Redmi Note 8 mediante Tapatalk
 

tglaria

InExperto

tglaria

InExperto
No hay caso, no puedo hacer funcionar el router como repetidor.
Al crear una red WiFi deja de darme IP el router.

Imágenes de mi configuración:
Interfaces:
1592367748433.png

LAN:
2020-06-17 00_18_51-LEDE - Interfaces - LuCI.png

2020-06-17 00_19_53-LEDE - Interfaces - LuCI.png

Relay:
1592367816262.png

1592367830498.png


WIFI:
1592368035227.png


WWAN
1592368153288.png



Y probando, por cable me funciona.
El DHCP funciona, agarro IP del rango del módem, me conecto a internet y puedo hacer ping entre equipos.
Pero agrego una interfaz inalámbrica y se jode todo, deja de funcionar el DHCP.
 

Archivo adjunto

Exte3

Capo
Cuando dices qué conectas por cable es wan por cable o los dispositivos?

Enviado desde mi Redmi Note 8 mediante Tapatalk
 

Exte3

Capo
Tienes la versión más actualizada de OpenWRT del dispositivo?


Enviado desde mi Redmi Note 8 mediante Tapatalk
 

FcoDragonBlack

Miembro Activo
yo en mi caso realice de este tutorial de youtube de un linksys e900 me funciona perfecto conectado al router blanco de vtr wifi nextgen por unos dias y despues de cae , he dejado los canales estaticos , he cambiado cuanta configuracion , pienso que el router de vtr es el problema
 

tglaria

InExperto
yo en mi caso realice de este tutorial de youtube de un linksys e900 me funciona perfecto conectado al router blanco de vtr wifi nextgen por unos dias y despues de cae , he dejado los canales estaticos , he cambiado cuanta configuracion , pienso que el router de vtr es el problema
Hice eso y no me funcionó.
Mismo atado: no agarro IP.
 

luisfebar

Weno pa la Chela :D
Borra todo lo que hiciste, reinicia de fábrica el router con open, tienes que poner una ip distinta al router si tu router es 1.1 la puerta de enlace del repetidor es 2.1, conectate directo a la red wifi que quieras utilizar y activa el puente en la interfaz lan, es más webeo crear el bridge como una nueva interfaz, fijate tb, de haber activado el firewall para cada conexión lan/wan, y al parecer no te funciona ya que debes tener un conflicto en con las IP.
(lo sabes, por que el icono de red de windows te aparece con conexión a internet pero no tienes.
 
Subir