USB no funciona al encender en Raspberry PI 4

galansinchance

enajenao
Se incorporó
3 Enero 2006
Mensajes
7.408
Hola, no sé si alguien tendrá información de esto, llevamos años instalando unos lectores de QR en Raspberry pi, antiguamente los hacíamos en Arduino pero la versatilidad de la PI nos hizo cambiarnos a esa plataforma.

El tema es que hace poco compramos unas PI 4 para un proyecto y lo que ocurre es que cuando el lugar donde están instaladas, se corta la energía, al volver la PI se inicia, pero el lector no se energiza y queda apagado, como si no recibiese energía, tenemos que ir, desconectarlo y volverlo a conectar y toma.

Qué podrá ser? he intentado varias cosas como el aumentar el max_usb_current, pero no funcionó =(.
 

unreal4u

I solve problems.
Miembro del Equipo
ADMIN
Se incorporó
2 Octubre 2005
Mensajes
12.609
a qué puerto USB está conectado? 2.0 o 3.0 ?

Probaste enchufándolo a otro puerto?

Saludos.

PD: Lo otro: cuánta corriente chupa el aparato conectado?
 

galansinchance

enajenao
Se incorporó
3 Enero 2006
Mensajes
7.408
a qué puerto USB está conectado? 2.0 o 3.0 ?

Probaste enchufándolo a otro puerto?

Saludos.

PD: Lo otro: cuánta corriente chupa el aparato conectado?
Cualquiera de los 4, ninguno funciona, buceando en otros foros indican como workaround usar un powered usb hub, ando mirando a ver si en alguna parte encuentro.
 

unreal4u

I solve problems.
Miembro del Equipo
ADMIN
Se incorporó
2 Octubre 2005
Mensajes
12.609
Sí, también sospecho que es por el tema de la corriente:

Qué fuente de poder estás usando? Cuánto amperaje? Y cuánta corriente chupa el aparato que tratas de conectar?

Lo pregunto pq es esencial saberlo: durante booteo es donde más corriente chupa la rpi, y si no puede darle el poder que requiere el puerto USB lo cerrará hasta que lo vuelvas a conectar.

Saludos.
 

galansinchance

enajenao
Se incorporó
3 Enero 2006
Mensajes
7.408
Uso la fuente original, de 3A 5V, osea en mi opinión también apunta a que es un problema de corriente, la Pi 3 al parecer chupa harto menos ya que la tengo con una fuente de 2,4A y anda bien con el lector QR.

Desconozco cuánto consume, tengo otro lector en versión RS232 y la fuente con la que viene es de 1A.
 
Subir